Pseudocódigo

Enviado por Programa Chuletas y clasificado en Informática y Telecomunicaciones

Escrito el en español con un tamaño de 2,08 KB

 
PROGRAMA letras hasta s y cuenta a
ENTORNO
c es un caracter
cont es entero
ALGORITMO
cont = 0
c = 'p'
MIENTRAS (c <> 's') HACER
ESCRIBIR "Pulsa una letra"
LEER c
SI (c == 'a') ENTONCES
cont = cont + 1
FINSI
FINMIENTRAS
ESCRIBIR "La letra 'a' se ha pulsado", cont, "veces".
FINPROGRAMA


PROGRAMA cacula areas
ETORNO
area, r, l, a son enteros
opción es caracter
ALGORITMO
ESCRIBIR "Introduzca 'c' para calcular el área del círculo y 'r' para la del rectángulo"
LEER opcion
SI (opcion == 'c') ENTONCES
ESCRIBIR "Diga un radio"
LEER r
Area = 3,14*r*r
ESCRIBIR "La superficie es", area
SINO
SI (opcion == 'r') ENTONCES
ESCRIBIR "Dame largo y acho"
LEER l, a
Area = l*a
ESCRIBIR "Superficie es", area
FINSI
FINSI
FINPROGRAMA