Algoritmo

Enviado por Programa Chuletas y clasificado en Matemáticas

Escrito el en español con un tamaño de 1,22 KB

 
ALGORITMO N_PRIMEROS_PRIMOS ENTORNO NUMERO es Entero; /*números de primos que se quieren*/ CONTADOR es Entero; /*contara cuantos numero primos tenemos*/ POSICION es Entero; POSAUX es Entero; /*muestra hasta que numero llegamos [1..posicion]*/ CONTDIV es Entero; /*para contar las divisiones*/ INICIO Escribir (â¿Cuántos números primos quieres?â); Leer (NUMERO); CONTADOR=0; POSICION=1; Mientras (CONTADOR < NUMERO) hacer POSAUX=POSICION; CONTDIV=0; Mientras (POSAUX>=1) Y (CONTDIV<=2) hacer Si (POSICION MOD POSAUX= 0) entonces CONTDIV=CONTDIV+1; Fin si POSAUX=POSAUX-1; Fin mientras Si CONTDIV>2 entonces Escribir (âel numeroâ+POSICION+âno es primo); Sino Escribir (âel númeroâ+POSICION+âes primoâ); CONTADOR=CONTADOR+1; Fin si POSICION=POSICION+1; Fin mientras FIN

ALGORITMO PALINDROMOS ENTORNO I,J es Entero; V [1â¦9] es Entero; IGUAL es Logico; INICIO V=âRECONOCERâ I=1 J=9 IGUAL=VERDADERO; Mientras IGUAL=VERDADERO Y I>5 hacer Si V[I]=V[J] entonces I=I+1; J=J-1; Sino IGUAL=FALSO; Fin si Fin mientras Si IGUAL=VERDADERO entonces Escribir (âes igualâ); Sino Escribir (âno es igualâ); Fin si FIN

Entradas relacionadas: